Forum Home Forum Home > Moped2.org Forums > Moped
  New Posts New Posts RSS Feed - Suzuki FA50 poor acceleration
  FAQ FAQ  Forum Search   Events   Register Register  Login Login


Suzuki FA50 poor acceleration

 Post Reply Post Reply Page  123 4>
Author
Message
kbalona View Drop Down
Newbie
Newbie


Joined: April/22/2006
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote kbalona Quote  Post ReplyReply Direct Link To This Post Topic: Suzuki FA50 poor acceleration
    Posted: April/22/2006 at 4:01pm
I just bought a Suzuki FA50 scooter. It needed new rings & piston in it. Now I started it up for the first time, it accelerates very poorly, top speed of 15 mph on a flat area. The carb was supposedly cleaned recently. I'm gonna try taking the muffler off, see if it goes better without. I'll clean it while its off. The two screws on carb, where should they be? Also there's one hose off the carb thats just sticking up...not connected to anything. Is that correct? anyone have a owners manual to share? ANd the little spout on bottom of carb, is that an overflow of some type? gas leaks out it when I'm starting the scooter. If anyone has tweaking tips...I need it.
Back to Top
Sponsored Links


Back to Top
Joe33 View Drop Down
Newbie
Newbie


Joined: May/05/2006
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Joe33 Quote  Post ReplyReply Direct Link To This Post Posted: May/05/2006 at 5:42pm
Check the exhaust port after you take off the muffler. I had to scrape the carbon from the inside of the exhaust port on ours. That made it go faster. The right screw on the carb should be turned all the way in and then out 1 3/4 turns. The left screw is your idle adjustment 1500 + or - 150RPM. There should be a screw on the carb bowl. Make sure that it is in all the way in to stop the leak.
Back to Top
toma View Drop Down
Newbie
Newbie


Joined: June/05/2006
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote toma Quote  Post ReplyReply Direct Link To This Post Posted: June/05/2006 at 6:32pm
Hi,

I just bought a Suzuki FA50. It runs fine, however, it leaks gas when the scooter is running. It seems like the leak is from the spout at the bottom of the carburator also. i have nothing attached to this spout. Is this correct? I am not too familiar with bikes and i am learning, but is there an o-ring on the screw you are referring to? My O-ring is completely shredded. Where can I get this o-ring.

Thanks, toma
Back to Top
xraywhf View Drop Down
Newbie
Newbie


Joined: July/21/2006
Location: United States
Status: Offline
Points: 26
Post Options Post Options   Thanks (0) Thanks(0)   Quote xraywhf Quote  Post ReplyReply Direct Link To This Post Posted: July/21/2006 at 9:01pm
Go here: I found it whilst googling for parts on the '85 I rescued from a laundry room.
http://www.alpha-sports.com/suzuki_parts.htm
They seem to have a plethora of parts and don't seem to charge a lot.
All I really need for mine is the speedo bushing, an Ignition Switch assembly, a battery, and a seat cushion, (so far). It will be cool if I can make it go.
Wayne H. Franklin
Back to Top
Tanman902000 View Drop Down
Newbie
Newbie
Avatar

Joined: August/31/2006
Location: United States
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tanman902000 Quote  Post ReplyReply Direct Link To This Post Posted: August/31/2006 at 8:10pm
I have a Fa50 suzuki. I cleaned my carb and I dont know if I put the connection right. There is two lines near to the valve, which valve goes to which. Is it the shorter rubber hose goes to the nearest kick start. And is the longest one goes to the choke plunger. Also on the bottom of the spout where does it go to, is it to the side of the carb. Plz help me!!!!!!!!!!!!!!!!!!
Back to Top
 Post Reply Post Reply Page  123 4>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

All my sites | Web Wiz Hosting Services | Privacy policy